Zh YandexMap, big changes to support API v2.1

Home / Joomla! / Extensions / Zh YandexMap, big changes to support API v2.1

Всем привет.

Я обновил расширение (все его части), и теперь по умолчанию используется версия АПИ 2.1

В настройках компонента вы можете выбрать предудыщие версии (2.0 и 1.x)

Что нового из АПИ 2.1 реализовано:

  • кнопка определения местоположения (может принимать стандартную иконку)
  • кнопка полноэкранного просмотра карты
  • кнопка измерения расстояний

Что изменено по сравнению с 2.0

  • кнопки не располагаются в тулбаре (тулбар больше не поддерживается API 2.1)
  • обзорная карта не поддерживается в 2.1
  • для элементов управления добавлены дополнительные значения по местоположению (прижатые вправо, влево – это помимо отступов и точного указания где расположены)

Исправления для 2.0 и 2.1

  • провайдер поиска изменен на обычный (после внесения народной карты в список карт яндекса тип провайдера изменился)
  • для пользовательских типов карт добавлены параметры мин. и макс. масштабов (иначе были трудности с бОльшими значениями)
  • в настройках карты можно подавить ссылку на переход в Яндекс.карты

Особое внимание следует уделить тому, что предопределенные типы меток (иконки), которые не из файла – изменили наименование (они разные для разных АПИ). В настройках метки кнопка об использовании в зависимости от версии АПИ отсылает на разные страницы.

Карты в админке также используют версию из настроек компонента.

 

Leave a Reply

Your email address will not be published. Required fields are marked *